ac-versailles.assistance-technique.samba-edu

Sujet Auteur Date
GRUB qui s'est fait la malle - Serveur hors d'usage - Migration SqueezeToWheezy jeremy violette 2017/12/19 21:28
Re: GRUB qui s'est fait la malle - Serveur hors d'usage - Migration SqueezeToWheezy Louis-Maurice De Sousa 2017/12/20 07:50
Re: GRUB qui s'est fait la malle - Serveur hors d'usage - Migration SqueezeToWheezy jeremy violette 2017/12/20 19:16
[RESOLU] Re: GRUB qui s'est fait la malle - jeremy violette 2018/01/24 20:48

[RESOLU] Re: GRUB qui s'est fait la malle -

jeremy violette, le 2018/01/24 20:48

Hello à tous,

Juste pour tenir informé des évolutions et des résolutions au cas où
quelqu'un serait dans le même cas...

Donc comme je l'avais dit j'ai réussi à réinstaller le GRUB en utilisant
la procédure chroot décrite dans la doc.

Mais une fois le serveur redémarré, j'ai obtenu le message suivant qui
s'affichait en boucle :
"[... ...] XFS : possible memory allocation deadlock in
knem-zone-alloc>(Mode : 0x2d0)"

Donc la solution était matérielle, le serveur possédait 2Go de RAM mais ça
ne suffisait pour redémarrer. Nous avons donc rajouter 2 Go e RAM, et là
tout roule ;)

A bientôt
Jérémy
Collège La Nacelle
Corbeil-Essonnes


jeremy violette écrivait :

>Hello à tous,

>

>Merci Louis Maurice, effectivement j'avais la version grub1, j'ai essayé

>la procédure avec Super-Grub mais ca n'a pas fonctionné, alors en dernier

>espoir j'ai retenté la procédure chroot et là miracle lors du reboot un

>joli "Welcome to Grub" et le système démarre ouf!

>

>Enfin lors de ce démarrage voilà ce que j'ai obtenu :

>

>"[... ...] XFS : possible memory allocation deadlock in knem-zone-alloc

>(Mode : 0x2d0)" les points entre crochet sont des nombres qui augmentent

>au fur et à mesure, au bout de plus de 2h j'ai donc une succession de

>lignes et j'ai atteint [9525.876010]

>

>J'ai choisi de laisser tourner le serveur cette nuit comme cela en pensant

>qu'il était en train de checker les blocks des disques dur et peut être

>lorsqu'il aura terminé, le serveur sera démarré correctement...

>

>donc voici mes questions :

>Est-ce normal d'obtenir ces lignes ? (je n'ai pas trouvé grand chose sur

>le net, peut être un problème lié à la version du noyau linux, mais pas

>très clair encore pour moi)

>S'il n'est pas démarré demain matin et que des lignes s'affichent encore,

>que dois-je faire ? le laisser continuer ou le relancer ?

>Et lors du reboot comment faire en sorte que ces lignes n'apparaissent

>plus ?

>

>Si quelqu'un a déjà rencontré ce problème... ou a des idées, là je bloque

>un peu car je n'ai la main sur rien et ne voit pas trop s'il y a un

>problème, contrairement au début où j'avais bien compris qu'il y avait un

>problème avec GRUB.

>

>Merci d'avance

>>Jérémy VIOLETTE,

>>Référent Numérique

>>Collège La Nacelle, 8 rue de la nacelle

>>91100 Corbeil-Essonnes

>

>

>